IT Essentials: PC Hardware and Software v4.1
                                     Chapter 12 – Lab/Student 

12.2.4 Optional Lab: Customize Settings in Windows Vista
Introduction

Print and complete this lab.

This lab is comprised of five parts. This lab is designed to be completed in multiple lab sessions.

Part 1: Managing Virtual Memory, Startup Options, and Windows Update in Windows Vista
In this part of the lab, you will customize Virtual Memory settings. You will customize the Startup Folder and RunOnce Key in the Registry. You will change the default Windows Update option.

Recommended Equipment

· A computer running Windows Vista
· Internet access

Step 1

Log on to Windows as an Administrator.
Click Start > Computer. 

The Computer window appears.

Step 2
Double-click the Local Disk (D:) drive.

Click Format disk > Continue to confirm the drive D: is to be formatted.
Step 3
The Format Local Disk (D:) window appears.
Select NTFS in the File system drop-down menu.

Click Start.
A warning window appears.

Click OK.

Windows formats the drive.

When the Format Complete message appears, click OK.

The Format Local Disk (D:) window re-appears.  

Click Close.
Close all open windows.
Step 4
Click Start > Control Panel > System > Advanced system settings.

The System Properties window appears.

Select the Advanced tab and then click Settings in the Performance area.
Step 5
The Performance Options window appears.

Click the Advanced tab.
What is the current size of the Virtual Memory (paging file)?
Click Change in the Virtual Memory area.
The Virtual Memory window appears.

Remove the check mark from Automatically manage paging file size for all drives.

What Drive [Volume Label] contains the paging file?

Choose the D: drive.

Click the Custom size radio button.

Look at the recommended size in the Total paging file size for all drives section of the Virtual Memory window.

Type the recommended file size in the Initial size (MB): field.

Type the recommended file size again in the Maximum size (MB): field.

Click Set.
Select the C: drive.

Click the No paging file radio button, and then click Set.

The System Properties warning message appears.

Click Yes to continue.
Click OK to accept the new virtual memory settings.
The System Properties restart warning message appears.

Click OK.

The Performance Options message window appears. 

Click OK.
The System Properties message window appears. 

Click OK.
The You must restart your computer to apply these changes message appears, click Restart Now.

Step 6
Log on to Windows as an Administrator.

Open the Virtual Memory window.

What Drive [Volume Label] contains the paging file?

Click Cancel to close all open windows.
Step 7
Click Start > All Programs > Games > right-click FreeCell > Send To > Desktop (create shortcut). 
Step 8
Click and drag the shortcut FreeCell icon to the Start button. 
The Start menu appears.

Do not release the shortcut icon.

Drag the icon to All Programs.

The All Programs menu appears.

Drag the icon to the bottom of the Startup folder.
When a blue arrow appears next to the FreeCell shortcut icon, release the icon.

Click Startup.

You should see the FreeCell icon listed below Startup.
Step 9
Log off Windows.

Log on to Windows as an Administrator.

What happens when you log in?

Close the Freecell application.

Step 10
Click Start > Start Search > type run.
Type regedit In the Open: field > OK > Continue.
CAUTION:
Incorrect changes to the registry can cause system errors and/or system instability.
The Registry Editor window appears.

Expand the HKEY_CURRENT_USER Key.
Expand the Software Key.
Expand the Microsoft Key.

Expand the Windows Key.

Expand the CurrentVersion Key.

Select the RunOnce Key.

Right-click anywhere in the white space on the right side of the window.

Hover over New and select String Value.

Click anywhere in the white space of the window.

Right-click New Value #1 > Rename.
Type Solitaire and press Enter.

Right-click Solitaire > Modify. 

Type C:\Program Files\Microsoft Games\Solitaire\Solitaire.exe in the Value data field.

Click OK.
Close the Registry Editor window.

Step 11
Log off Windows.

Log on to Windows as an Administrator.

What happens when you log in?

Close all open Windows.
Step 12
Click Start > Control Panel > double-click Windows Update > Change settings.

Note: The newest Windows Vista Update program has a different user interface. Both the original and new user interface are shown here.

Click the Download updates but let me choose whether to install them radio button.
Original Windows Vista Update program

New Windows Vista Update program

Click OK > Continue.
Step 13
Windows checks for updates.

The New updates are available balloon appears.

Double-click the shield icon in the system tray.

Click the link that shows how many updates have been downloaded. Example: 50 important updates are available.
The Select updates to install window appears.

Place a check mark next to the important and optional updates to be installed, and then click OK. 
When the Windows Update window appears click Install updates.

The Installing updates… balloon appears.

You have successfully completed this part of the lab once the Installing updates… balloon appears.

Reboot the computer.
Part 2: Windows Vista Hard Drive Maintenance
In this part of the lab, you will examine the results after using Disk Check and Disk Defragmenter on a hard drive.

Recommended Equipment

· A computer running Windows Vista
Step 1
Log on to Windows as an administrator.
Start > Computer > double-click New Volume (G:).
Right-click anywhere in the white space of the folder area for drive G: > Properties > Tools tab > Check Now > Continue.

The Check Disk New Volume (G:) window appears. Make sure there is not a check mark in either check box then click Start.
When the Your device or disc was successfully scanned screen appears, click the expand button next to See details.

How many stages were processed?

Click Close.

Select the Tools tab, click Check Now > Continue. Remove the check mark next to Automatically fix file system errors. Place a check mark in the check box next to Scan for and attempt recovery of bad sectors > Start.

When the Your device or disc was successfully scanned screen appears click the expand button next to See details.

What stages were processed?

Click Close.

Select the Tools tab, click Check Now.

Place a check mark in both check boxes then click Start.

An information window opens.

Why will Check Disk not start?

Note: This message is displayed because a boot partition will be scanned, or a non-boot partition that is going to be scanned is open. 

Click Schedule disk check and then OK to close the New Volume (G:) Properties window.
Make sure drive G: stays open.

Note: To force CHKDSK to create a log file, when it scans a non-boot partition with no bad sectors, the non-boot partition drive must be open.

Click Start > hover over the right arrow button > Restart.

Step 2
The Checking file system on G: screen appears.

How many stages in the scan are there?

What is being verified in each of the stages?

Were any problems found with the volume?

If so what are they?

Step 3
Log on to Windows as an administrator.
Start > Control Panel > Administrative Tools > Event Viewer > Continue. In the left pane expand Windows Logs > select Application.
Double-click the top event in the right pane. Click the black down arrow until the Disk Check event appears.
Which stages are shown as completed?

Close all open windows.

Step 4
Start > My Computer > right-click drive (C:) > Properties > select Tools tab > click Defragment Now button > Continue.

The Disk Defragmenter window appears. 
Click Defragment now.

The Disk Defragmenter: Defragment Now window appears. Make sure there is a check mark only next to drive (C:). 

Click OK.

Windows starts defragmenting hard drive (C:).

When defragmenting is completed close all windows.

Note: It is not possible to view the detail of the defragmented hard drive through the GUI version of defragmenter.

Part 3: Managing Processes, and Regional and Language Settings in Windows Vista
In this part of the lab, you will examine regional and language settings, and explore how to manage processes in Task Manager.

Recommended Equipment

· A computer running Windows Vista
Step 1
Log on to Windows as an administrator.
Press keys Ctrl-Alt-Delete > click Start Task Manager > Processes tab. 
Click Show processes from all users.

Double-click the border around the tabs.

Windows Task Manager is now in compact mode.

Click Image Name.

Click Image Name again.

What effect does this have on the columns?

Click Memory (Private Working Set).
What affect does this have on the columns?

Double-click the outside border again to return to tabs mode.

Step 2
Open a browser. 

Note: Firefox is used in this lab. However, any browser will work. Just substitute your browser name whenever you see the word Firefox.

Return to the Windows Task Manager.
Click Image Name so the list is in alphabetical order, then locate and select firefox.exe.

Right-click firefox.exe > Set Priority.

What is the default priority for the browser?

Set the priority to Above Normal.
Click Change priority to the Windows Task Manager warning message.
Step 3
Expand the width of the Windows Task Manager window.

Click View > Select Columns.
Place a check mark next to Base Priority > click OK.

Click Base Pri.

Which image name has a base priority of N/A?

List one image name that has a base priority of Above Normal?

Step 4
Reset Firefox.exe base priority to Normal > Change priority.
Click View > Select Columns > uncheck Base Priority > OK.
Close Firefox. 

Is Firefox listed as a process?

Step 5
Click Start > Control Panel > Regional and Language Options.

The Regional and Language Options appears.
What regional options format is being used?

Click Customize.

What are the tabs that can be customized?

Click Cancel.

Click the dropdown menu in Current formats area. Select Belarusian.

Notice the changes to the output in the Example of how data is displayed using this format: fields.

Click the dropdown menu in the Current format area.
Return the setting to the original format.

Click Keyboard and Languages tab > Change keyboards.

What is the default input language?

Click Cancel > Cancel to close Regional and Language Options window.

Step 6
Right-click the Taskbar.

Select Toolbars > Language bar to ensure that the Language bar is shown in the Taskbar.
Right-click the Language bar in the Taskbar.

Select Settings.

What is the Default input language?

Part 4: Managing Windows Vista System Performance
In this part of the lab, you will manage and monitor Windows Vista system performance.
Recommended Equipment

· A computer running Windows Vista
Step 1
Log on to Windows as an administrator.
Click Start > Control Panel > Administrative Tools > Windows Defender.
Click Start > Control Panel > Administrative Tools > Computer Management > Continue > expand Services and Applications > select Services.

Close the Administrative Tools window.

Resize and position both windows so they can be seen at the same time.

Can Windows Defender check for updates?

Scroll the Computer Management window so you see the Windows Defender service.

What is the Status of the service?

Right-click Windows Defender service > select Stop.

Note: The reason this service will be stopped is so you can easily see the results. When stopping a service, to free up system resources the service uses, it is important to understand how the overall system operation will be affected.

The Service Control window appears and closes.

Select the Windows Defender window so it is active.

What must be done so Windows Defender can run?

What step must be followed to start the Windows Defender service?
Start the Windows Defender service.

Select the Windows Defender window so it is active.

Can Windows Defender check for updates?

Close the Windows Defender window.

Step 2
Make sure the Computer Management window is open.

Expand Event Viewer > Windows Logs > select System.

Select the second event in the list.

Look below the General tab then explain what has happened to the Windows Defender service.
Click the up arrow button on the keyboard or select the event above this one.

Look below the General tab then explain what has happened to the Windows Defender service.
Close all opened windows.

Note: NVDA is Highly recommended for this next section! This comes pre-installed on your Virtual Machine, or ask your instructor for more information.

Step 3
Click Start > Control Panel > Administrative Tools > Reliability and Performance Monitor > Continue.

Expand Data Collector Sets > right-click User Defined > New > Data Collector Set.

The Create new Data Collector Set window appears.

In the Name field, type Memory Logs. Select the Create manually (Advanced) radio button > Next.

Select Performance counter > Next.

Click Add.

From the list of available counters locate and expand Memory. Select Available MBytes > Add.

Click OK.

Set the Sample interval field to 4 seconds. Click Next.

Click Browse.

Select drive (C:) > Make New Folder > type PerfLogs > OK.

The create new Data Collector Set window appears.

Click Next.

Click Finish.

Step 4
Expand User Defined > select Memory Logs > right-click Data Collector01 > click Properties.
The DataCollector01 Properties window appears.
Change the Log format: field to Comma Separated.

Select the File tab.

What is the full path name to the example file name?

Click OK.

Step 5
Select the Memory Logs icon in the left pane of the Reliability and Performance Monitor window.
Click the green arrow icon to start the data collection set.

Step 6
To force the computer to use some of the available memory, open and close a browser. 
Click the black box icon to stop the data collection set.

What change do you notice for the Memory Logs icon?

Step 7
Click Start > Computer > double-click drive C: > PerfLogs > 00001 > Continue.
Double-click DataCollector01 text file.

What does the column farthest to the right show?

Step 8
Close the DataCollector01 text file and the window with the PerfLogs folder.
Select the Reliability and Performance Monitor window. Right-click Memory Logs > Delete.
Open drive C: > right-click the PerfLogs folder > Delete > Yes.

Close all open windows.

Note: this portion of the lab is not required for accessibility reasons.
Part 5: Managing Windows Vista Remote Access
In this part of the lab, you will remotely connect to a computer, examine device drivers, and provide remote assistance.

Recommended Equipment

· Two computers running Windows Vista that are directly connected to each other or through a switch or hub.

· The two computers must be part of the same Workgroup and on the same subnet.

Step 1

Log on to Computer2 as a member of the administrator group. Ask your instructor for the user name.
Click Start > Control Panel > System > Remote Settings. 
In the Remote Desktop area, select the radio button next to Allow connections only from computers running Remote Desktop with Network Level Authentication (more secure).
If a message appears warring the computer is set to go to sleep, click the Power Option link and then change the settings to Never > Save changes. 

Click OK to close the warning message.

Click Apply in the System Properties window.
In the Remote Desktop area, click the Select Users button.

Which user already has remote access?

Since you will use this account to gain remote access, you do not need to add any users, click Cancel.

Click Start > Control Panel > Windows Firewall > Change Settings. 
Make sure the On (recommended) radio button is selected then click OK.

Close the Control Panel window, the Windows Firewall window, and move to Computer1.
Step 2
Log on to Computer1 as an administrator or a member of the administrator group. Ask your instructor for the user name.
Click Start > All Programs > Accessories > Remote Desktop Connection. 
When the Remote Desktop Connection window appears, type Computer2 in the Computer field and click Connect.
In the User name field, type the account name you used to log on to Computer2. For example: John_Computer2. 

In the Password field, type the password for the user.

Note: The user account must have a password.

Click OK.

What happened to the desktop of Computer2?

What happened to the desktop of Computer1?

Step 3
From Computer1, right-click the desktop of Computer2 > New > Folder > name the folder Remote Permission.

Right-click the Remote Permission folder > Sharing > Advanced Sharing > Share this folder checkbox > keep the default name Remote Permission > OK.

Click the Security tab. Make sure the user name from Computer1 is listed in Computer2. If it is not, create and add the user name.

Click OK > Close.
Click Start > Disconnect.
Step 4
Log on to Computer2.
Select the System Properties window.
Notice Remote Assistance is activated by default.
Click Advanced.

The Remote Assistance Settings window appears.

Make sure there is a check mark in the Allow this computer to be controlled remotely checkbox, set the invitation to 1 Hours, place a check mark in the Create invitations that can only be used from computers running Windows Vista or later checkbox, and then click OK.

When the System Properties window appears, click Apply.

Step 5
On Computer2, click Start > All Programs > Maintenance > Windows Remote Assistance.

The Do you want to ask for or offer help? screen appears.

Click Invite someone you trust to help you.

The How do you want to invite someone to help you? screen appears.

Which methods can you use to contact someone for assistance?

Click the Save invitation as a file.

When the Save the invitation as a file screen appears, click Browse.

Locate the shared Remote Permission folder, and name the file Invitation to Computer1.

What type of extension does the file have?

 Click Save.

When the Save the invitation as a file screen appears, type the password HelpMe and confirm the password HelpMe. Click Finish.

When the Waiting for incoming connection screen appears click Settings.

What key must you press to stop sharing control?

Which features are disabled with a Medium bandwidth usage?

Click OK.

Step 6
On Computer1, click Start > Network > double-click Computer2.

Log on with the user account from Computer1. Double-click the folder Remote Permission on Computer2. Double-click the file Invitation to Computer1.
When the Remote Assistance window appears, type in the password HelpMe.

Click OK.

Step 7
From Computer2, answer Yes to allow access to the computer.

Select the Windows Remote Assistance – Being helped by John_Computer1 window so it is activated.

Click Chat.

In the chat field type Hi John_ Computer1, my optical drive will not work. Click Send.

Step 8
From Computer1, click the Request control button in Windows Remote Assistance main menu.

Step 9
From Computer2, click the Allow John_Computer1 to respond to User Account Control prompts checkbox. Click Yes.

Step 10
From Computer1, select System Properties window for Computer2.

Note: If the Computer2 System Properties window is closed, you need to open it before you continue. 

Click Hardware tab > Device Manager.

Right-click the optical drive that has a black down arrow. Select Enable.

Click the Stop Sharing button in Windows Remote Assistance main menu.

Click the Disconnect button in Windows Remote Assistance main menu.

Click Yes.

Close all open windows and log off Computer1.

Step 11
On Computer2, click Yes.

Click on Device Manager so it is activated.
Dose the optical drive have a black arrow?

Close the Device Manager window and the Windows Remote Assistance window.

Delete the Remote Permission folder. 

Select the System Properties window. Place a check mark next to Don’t allow connection to this computer > OK.

Log off Computer2.

© 2007-2010, Cisco Systems, Inc. All rights reserved.
Page 1

