IT Essentials: PC Hardware and Software v4.1

Chapter 12 – Lab/Student 

12.2.2 Optional Lab: Advanced Installation of Windows Vista 

Introduction

Print and complete this lab.
In this lab, you will install a Windows Vista operating system by using an answer file for automation. You will customize partition settings and create an Administrator user account and Users account. 

Recommended Equipment

The following equipment is required for this exercise:

· A computer with a new installation of Windows Vista 
· Windows Automated Installation Kit (WAIK) installation media
· Windows Vista installation media
· A blank, formatted floppy disk or a USB flash drive
Step 1

Ask the instructor for the following required information for the answer file:

Regional and language settings __________________________________________

Windows Vista Business product key ______________________________________

Partition sizes: Primary ___________ Logical 1 ___________ Logical 2 ___________
Administrator account: Username _________________________________________

        Password ___________________________________________

User account: Username ________________________________________________

          Password _________________________________________________

Computer name _______________________________________________________

Registered organization _________________________________________________

Registered owner ______________________________________________________

Time zone ____________________________________________________________
Step 2
Log on to the computer as administrator. 
Insert the Windows Automated Installation Kit (WAIK) DVD in the DVD-ROM drive. 
When the “AutoPlay” window appears, click Run StartCD.exe.
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The “Welcome to Windows Automated Installation Kit” window appears, click Windows AIK Setup.
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When the setup wizard appears click Next. 
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Select I Agree to license terms and then click Next.
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For the “Select Installation Folder” screen, keep the default settings and click Next.
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Click Next to confirm and start the installation.
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When the “Installation Complete” screen appears, click Close.
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Click Exit.

[image: image8.jpg]5 Welcome to Windows Automated Installation Kit ==

* &

Exit the DVD

MET Framework Secup

MSKML 6.0 Setup.

Exi

)





Step 3
Create a fold called “Vista_Installation” at the root of C:. Example: C:\Vista_Installation.
Insert the Windows Vista Business DVD in the DVD-ROM drive. 

Close the “Install Windows” if it opens.
Navigate and copy “install.wim” from the Windows Vista installation DVD to C:\Vista_Installation.

Note: The install.wim file is 2.6GB and may take several minute to copy.

Start > Computer > right-click the DVD drive > select Explore. Then double-click sources > right-click on install.wim > copy. 

Start > Computer > double-click C: drive > double-click Vista_Installation > right-click Paste. 
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Step 4
Start > All Programs > Microsoft Windows AIK > Windows System Image Manager. 
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Step 5
The “Windows System Image Manager” window appears.

Right-click Select a windows image or catalog file then click Select Windows Image.
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Brows to C:\Vista_Installation > select install.wim > click Open.
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Select Windows Vista BUSINESS > click OK.
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Click Yes to create a catalog file > Continue. This may take several minutes.
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A catalog file is generated in the Windows Image pane. 
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Right-click Create or open an answer file then click New Answer File.
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A new unconfigured answer file is created in the Answer File pane.
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To name the file select the root node Untitled.

Click File > Save Answer File > name the file autounattend. Make sure the Vista_Installation folder is selected then click Save.
Note: It is important to name the file “autounattend” as Vista will only search for that file name when performing an unattended installation. 
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Step 6
Regional and Language Options Settings
In the Windows Image pane, expand Components.
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Note: The actual name of the components will have a prefix and suffix attached, for example: x86_Microsoft-Windows-International-Core-WinPE_6.0.6000.16386_neutral. The prefix is “x86” and the suffix is “6.0.6000.16386_neutral”. For simplicity the prefix and suffix will be left out in the lab instructions.
Right-click Microsoft-Windows-International-Core-WinPE > select Add Settings to Pass 1 windowsPE.
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Notice Microsoft-Windows-International-Core-WinPE has been added to the Answer File and Properties panes.
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Select Microsoft-Windows-International-Core-WinPE in the Answer File pane. In the Microsoft-Windows-International-Core-WinPE Properties pane type the language settings provided by your instructor, in the following locations: InputLocale, SystemLocale, UILanguage, UILanguageFallback, and UserLocale. For example: en-us.
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Note: Place the curser next to a setting in the Properties pane and press the F1 key to view Windows Help file for the setting. Supported regional and language settings are located here: http://technet.microsoft.com/en-us/library/cc722435(WS.10).aspx.
In the Answer File pane expand Microsoft-Windows-International-Core-WinPE > select SetupUILanguage. In the SetupUILanguage Properties pane type the language settings provided by your instructor, in the UILanguage location. For example: en-us.
Confirm OnError is selected for WillShowUI.
[image: image23.jpg]B Properties
AppiedCorfigurationPass
Component

Path

1 windowsPE
Microsoft Windows-temational-Core-Wir
SetupUiLanguage

Onmor





Step 7
End User License Agreement and Windows Vista Product Key Settings
In the Windows Image pane locate and expand component Microsoft-Windows-Setup > right-click UserData > select Add Setting to Pass 1 windowsPE.
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Select UserData in the Answer File pane. In the UserData Properties pane click in the box to the right of AcceptEula. Click the drop-down arrow and select true. 
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In the Answer File pane expand UserData > select ProductKey. In the ProductKey Properties pane click in the box to the right of Key and enter the Windows Vista Business product key provided by the instructor. 
Next click in the box to the right of the WillShowUI > select Never from the drop-down arrow.
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Step 8
Hard Drive Partition Settings
In the Windows Image pane locate and expand component Microsoft-Windows-Setup\DiskConfiguration > right-click Disk > select Add Setting to Pass 1 windowsPE.
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Select Disk in the Answer File pane. In the Disk Properties pane click in the box to the right of DiskID and type the number 0. Also set WillWipeDisk to true.
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In the Answer File pane expand Disk[DiskID=”0”] > right-click CreatePartitions > select Insert New CreatePartition.
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Now add three more CreatePartition objects, for a total of four. 
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Select the top CreatePartion in the Answer File pane. In the CreatePartition Properties pane set the following values: Extend = false, Order = 1 and Type = Primary. For Size, use the primary partition size provided by the instructor. For example: Size = 15000.
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Notice that the newly configured partition moves to the bottom of the four CreatePartition objects.

Select the top CreatePartion in the Answer File pane. In the CreatePartition Properties pane set the following values: Extend = True, Order = 2, and Type = Extended.
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Select the top CreatePartion in the Answer File pane. In the CreatePartition Properties pane set the following values: Extend = false, Order = 3 and Type = Logical. For Size, use the logical 1 partition size provided by the instructor. For example: Size = 5000.
[image: image33.jpg]&1 autounatend
&1} Components
&3 1 windowsPE
{55 x86_Microsof Windows:temationsl Core-
s Vicrosof Windows-Setup_newral
&0 DiskCorfiguraton
£ DsDiscD=0]

B Properties
AppliedConfigurationP; 1 windowsPE.
Componert. Microsoft Windowss-Setup
KeyName Order
Path DiskConfiguraton Disk[Disk
B Settings |
Action Addisttem
Beend fake
Order 3
Sze. 5000
Type Logical





Select the top CreatePartion in the Answer File pane. In the CreatePartition Properties pane set the following values: Extend = false, Order = 4 and Type = Logical. For Size, use the logical 2 partition size provided by the instructor. For example: Size = 5000.
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In the Answer File pane right-click ModifyPartitions > select Insert New ModifyPartition.
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Now add two more ModifyPartition objects, for a total of three. 

Select the top ModifyPartion in the Answer File pane. In the ModifyPartion Properties pane set the following values: Action = AddListItem, Active = true, Extend = false, Format = NTFS, Label = Vista_Business, Letter = C, Order = 1, and PartitionID = 1.
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Select the top ModifyPartion in the Answer File pane. In the ModifyPartion Properties pane set the following values: Action = AddListItem, Active = false, Extend = false, Letter = E, Order = 2, and PartitionID = 2.
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Select the top ModifyPartion in the Answer File pane. In the ModifyPartion Properties pane set the following values: Action = AddListItem, Active = false, Extend = false, Letter = F, Order = 3, and PartitionID = 3.
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In the Windows Image pane locate and expand component Microsoft-Windows-Setup\DiskConfiguration\ImageInstall\OSImage\InstallTo > right-click InstallTo > select Add Setting to Pass 1 windowsPE.
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Select InstallTo in the Answer File pane. In the InstallTo Properties pane set the following values: DiskID = 0, and PartitionID = 1.
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Step 9
User Name and Password Settings
In the Windows Image pane locate and expand component Microsoft-Windows-Shell-Setup\UserAccounts\LocalAccounts > right-click LocalAccount > select Add Setting to Pass 7 oobeSystem.
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In the Answer File pane right-click LocalAccounts > select Insert New LocalAccounts.
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You should now have two LocalAccounts objects. 

First setup an Administrators account.

Select the top LocalAccount in the Answer File pane. In the LocalAccount Properties pane type the DisplayName and Name provided by your instructor. Example: John and John M.
Type Administrators for the Group.
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Expand LocalAccount[Name=”John M”] > select Password. In the Password Properties pane type the password, in the Value setting, provided by your instructor. Example: Pa$$w0rd.
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Now set up a Users account.

Select the top LocalAccount in the Answer File pane. In the LocalAccount Properties pane type the DisplayName and Name provided by your instructor. Example: Nathan and Nathan W.
Type Users for the Group.
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Expand LocalAccount[Name=”Nathan W”] > select Password. In the Password Properties pane type the password, in the Value setting, provided by your instructor. Example: Pa$$w0rd.
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Step 10
Computer Name, Registered Organization and Owner, and Default Theme Settings
In the Windows Image pane locate and right-click Microsoft-Windows-Shell-Setup > select Add Setting to Pass 4 specialize.
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Select Microsoft-Windows-Shell-Setup in the Answer File pane below component 4 specialize. In the Microsoft-Windows-Shell-Setup Properties pane type the ComputerName, RegisteredOrganization and RegisteredOwner provided by your instructor. Example: Computer1, Cisco, and John.
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Expand Microsoft-Windows-Shell-Setup in component 4 specialize of the Answer File pane, and locate and select Themes. In the Themes Properties pane set the following value: DefaultThemesOff = false.
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Step 11
PC Time Zone, Protection and Location Settings
In the Windows Image pane locate and expand component Microsoft-Windows-Shell-Setup > right-click OOBE > select Add Setting to Pass 7 oobeSystem.
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Select Microsoft-Windows-Shell-Setup in the Answer File pane below component 7 oobe System. In the Microsoft-Windows-Shell-Setup Properties pane type the time zone, in the TimeZone setting, provided by your instructor. Example: TimeZone = Pacific Standard Time.
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Now select OOBE in the Answer File pane. In the OOBE Properties pane set the following value: NetworkLocation = Work and ProtectYourPC = 3. This will disable automatically install updates.
Note: Normally you would set ProtectYourPC to 1, automatically install updates. But to reduce the installation time for this lab we will set the value to 3.
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Step 12
Validate and Save the Answer File

Before validating the answer file, expand all components in the autounattend file to make sure everything is properly added.
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If anything is missing go back over the lab and add the missing components or settings.

Click Tools > Validate Answer File.
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Select the Validation tab in the Messages pane. 
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If you see any error or warning messages, ask your instructor for assistance in correcting them before proceeding with the lab.

If there are no error or warning messages click File > Save Answer File.

Step 13
Copy the autounattend.xml file from C:\Vista_Installation to the root of the floppy disk or USB flash drive.
Insert the floppy disk in the floppy drive or connect the USB flash drive to a USB port.

Insert the Windows Vista Business DVD in the DVD-ROM drive. 

Restart the computer.

Step 14
When the “Press Any Key to Boot from CD or DVD” message appears, press any key on the keyboard. 
The installation of Windows Business will proceed in a completely unattended fashion, then Vista will run a performance check, and finally you will be presented with the logon screen.

Note: The system will flash on and off several times, restart several times, and other times only a black or blue screen will appear with nothing else shown during the installation.

Logon to the computer using the administrator name and password used in the autounattend file.

What was the name of the file used to automate the installation located on the floppy disk or USB flash drive?
How do you think automating the installation will help the IT Department if they have to repeat the procedure on 100 computers?
© 2007-2010, Cisco Systems, Inc. All rights reserved.
Page 11

