IT Essentials: PC Hardware and Software v4.1

Chapter 12 – Lab/Student

12.2.2 Optional Lab: Advanced Installation of Windows 7 

Introduction

Print and complete this lab.
In this lab, you will install a Windows 7 operating system by using an answer file for automation. You will customize partition settings and create an Administrator account and User accounts. 

Recommended Equipment

The following equipment is required for this exercise:

· A computer with a new installation of Windows 7
· Windows Automated Installation Kit (Windows AIK) installation media
· Windows 7 installation media
· A blank, formatted floppy disk or a USB flash drive
Step 1

Ask the instructor for the following required information for the answer file:

Regional and language settings __________________________________________

Windows 7 product key ______________________________________

Partition sizes: Primary ___________ Logical 1 ___________ Logical 2 ___________
Administrator account: Username _________________________________________

        Password ___________________________________________

User account: Username ________________________________________________

          Password _________________________________________________

Computer name _______________________________________________________

Registered organization _________________________________________________

Registered owner ______________________________________________________

Time zone ____________________________________________________________
Step 2
Log on to the computer as Administrator. 
Installation from a DVD-ROM: Insert the Windows Automated Installation Kit (AIK) DVD. 
When the AutoPlay window appears, click Run StartCD.exe. 
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Click Yes if prompted by User Account Control.
The Welcome to Windows Automated Installation Kit window appears, click Windows AIK Setup.
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When the setup wizard appears click Next. 
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Select I Agree to license terms and then click Next.
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For the Select Installation Folder window, keep the default settings and click Next.
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Click Next to confirm and start the installation.
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A window opens displaying the file installation progress.
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When the Installation Complete window appears, click Close.
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Click Exit.
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Step 3
Create a folder called Windows_7_Installation at the root of C:. 
Example: C:\Windows_7_Installation.
Insert the Windows 7 media in the appropriate drive. 

Close the Windows 7 media Install Windows window if it opens.
Navigate to D:\sources and copy install.wim and install_Windows 7 PROFESSIONAL.clg from the Windows 7 installation media to C:\Windows_7_Installation.

Note: The install.wim file is 1.94GB and may take several minute to copy.
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Step 4
Start > All Programs > Microsoft Windows AIK > Windows System Image Manager. 
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Step 5
The Windows System Image Manager window appears.

Right-click Select a Windows image or catalog file > Select Windows Image.

[image: image12.jpg]Insert Tools Help

BfbAXIPEB O

Creste or open an ansrerfie.

Close Windows Image





Browse to C:\Windows_7_Installation > install.wim > Open.
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Click Yes. Click Yes if prompted by User Account Control.
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A catalog file is generated in the Windows Image area. 
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Right-click Create or open an answer file > New Answer File.
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A new answer file is created in the Answer File area.
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To name the file select the root node Untitled.

Click File > Save Answer File > name the file autounattend. Make sure the Windows_7_Installation folder is selected and then click Save.
Note: It is important to name the file autounattend, as Windows 7 will only search for that file name when performing an unattended installation. 
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Step 6
In the Windows Image area, expand Components.
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Note: The name of the components will have a prefix and suffix attached, for example: x86_Microsoft-Windows-International-Core-WinPE_6.1.7600.16385_neutral. The prefix is x86 and the suffix is 6.1.7600.16385_neutral. For simplicity, the prefix and suffix will be left out in the lab instructions.
Right-click Microsoft-Windows-International-Core-WinPE > Add Settings to Pass 1 windowsPE.
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Notice that Microsoft-Windows-International-Core-WinPE has been added to the Answer File and Properties areas.
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Select Microsoft-Windows-International-Core-WinPE in the Answer File area. In the Microsoft-Windows-International-Core-WinPE Properties area, type the language settings, provided by your instructor, in the following locations: InputLocale, SystemLocale, UILanguage, UILanguageFallback, and UserLocale. For example: en-us.
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Note: Place the curser next to a setting in the Properties area and press the F1 key to view the Windows Help file for the setting. Supported regional and language settings are also located here: http://msdn.microsoft.com/en-ca/library/ms533052(VS.85).aspx
In the Answer File area, expand Microsoft-Windows-International-Core-WinPE > select SetupUILanguage. In the SetupUILanguage Properties area, type the language settings provided by your instructor in the UILanguage location. For example: en-us.
Confirm OnError is selected for WillShowUI.
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Step 7
In the Windows Image area, locate and expand the component Microsoft-Windows-Setup > right-click UserData > Add Setting to Pass 1 windowsPE.
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Select UserData in the Answer File area. In the UserData Properties area, click in the box to the right of AcceptEula > true. 
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In the Answer File area, expand UserData > ProductKey. In the ProductKey Properties area, click in the box to the right of Key and enter the Windows 7 product key provided by the instructor. 
Click in the box to the right of the WillShowUI > Never.
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Step 8
In the Windows Image area, locate and expand component Microsoft-Windows-Setup\DiskConfiguration > right-click Disk > Add Setting to Pass 1 windowsPE.
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Select Disk in the Answer File area. In the Disk Properties area, click in the box to the right of DiskID and type the number 0. Set WillWipeDisk to true.
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In the Answer File area, expand Disk[DiskID=”0”] > right-click CreatePartitions > Insert New CreatePartition.
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Add four more CreatePartition objects, for a total of five objects. 
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Select the top CreatePartition in the Answer File area. In the CreatePartition Properties area, set the following values: Extend = false, Order = 1, Size = 100 and Type = Primary. 
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Notice that the newly configured partition moves to the bottom of the five CreatePartition objects.

Select the top CreatePartition in the Answer File area. In the CreatePartition Properties area, set the following values: Extend = false, Order = 2 and Type = Primary. For Size, use the primary partition size provided by the instructor. For example: Size = 16000.
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Select the top CreatePartition in the Answer File area. In the CreatePartition Properties area, set the following values: Extend = True, Order = 3, and Type = Extended.

[image: image33.jpg]



Select the top CreatePartition in the Answer File area. In the CreatePartition Properties area, set the following values: Extend = false, Order = 4 and Type = Logical. For Size, use the logical 1 partition size provided by the instructor. For example: Size = 5000.
[image: image34.jpg]



Select the top CreatePartition in the Answer File area. In the CreatePartition Properties area, set the following values: Extend = false, Order = 5 and Type = Logical. For Size, use the logical 2 partition size provided by the instructor. For example: Size = 5000.
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In the Answer File area, right-click ModifyPartitions > Insert New ModifyPartition.
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Add three more ModifyPartition objects, for a total of four objects. 

Select the top ModifyPartition in the Answer File area. In the ModifyPartition Properties area, set the following values: Action = AddListItem, Active = true, Extend = false, Format = NTFS, Label = System Reserved, Letter = leave this blank, Order = 1, PartitionID = 1, and TypeID = 0x27. 
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Select the top ModifyPartition in the Answer File area. In the ModifyPartition Properties area, set the following values: Action = AddListItem, Active = false, Extend = false, Format = NTFS, Label = Local Disk, Letter = C, Order = 2, and PartitionID = 2.
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Select the top ModifyPartition in the Answer File area. In the ModifyPartition Properties area, set the following values: Action = AddListItem, Active = false, Extend = false, Letter = E, Order = 3, and PartitionID = 3.
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Select the top ModifyPartition in the Answer File area. In the ModifyPartition Properties area set the following values: Action = AddListItem, Active = false, Extend = false, Letter = F, Order = 4, and PartitionID = 4.

[image: image40.jpg]1 windowsPE
Microsoft-Windows Setup.
Order

"DiskConfiguraton/ Disk[DiskID="

AddListtem
false
false

aam





In the Windows Image area, locate and expand component Microsoft-Windows-Setup\DiskConfiguration\ImageInstall\OSImage\InstallTo > right-click InstallTo > Add Setting to Pass 1 windowsPE.
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Select InstallTo in the Answer File area. In the InstallTo Properties area, set the following values: DiskID = 0, and PartitionID = 2.
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Step 9
In the Windows Image area, locate and expand component Microsoft-Windows-Shell-Setup\UserAccounts\LocalAccounts > right-click LocalAccount > Add Setting to Pass 7 oobeSystem.
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In the Answer File area, right-click LocalAccounts > select Insert New LocalAccounts.
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You should now have two LocalAccounts objects. 

Setup an Administrators account.

Select the top LocalAccount in the Answer File area. In the LocalAccount Properties area, type the DisplayName and the Name provided by your instructor. Example: Vicki and Vicki M.
Type Administrators for the Group.
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Expand LocalAccount[Name=”Vicki M”] > Password. In the Password Properties area, type the password provided by your instructor in the Value setting. Example: Pa$$w0rd.
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Set up a User account.

Select the top LocalAccount in the Answer File area. In the LocalAccount Properties area, type the DisplayName and the Name provided by your instructor. Example: John and John M.
Type Users for the Group.

[image: image47.jpg]£ auounattend  Properties

&) Componerts AopiedConfguraonPass 7 oobeSystem
54 1 windowsPE Companent Microsot Windows:Shel-Seup
55 x86_Micosoh Windows:temationsl Core WiPE_newtral || Keyllame Neme.
Pah UserAcoourts/LocalAccounts/Log
& Settings
< 3 generize Acton Addistitem
i3 4speciaize Descrption
< 5audtSystem Dispayliame. John
i GaudtUser Group Users
-4l 7oobeSystem Name: John M

527 286 licroof indors-Shel-Setup_neutsl





Expand LocalAccount[Name=”John M”] > Password. In the Password Properties area, type the password provided by your instructor in the Value setting. Example: Pa$$w0rd.
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Step 10
In the Windows Image area, locate Microsoft-Windows-Shell-Setup > and right-click Themes > Add Setting to Pass 4 specialize.
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Select Microsoft-Windows-Shell-Setup in the Answer File area below component 4 specialize. In the Microsoft-Windows-Shell-Setup Properties area, type the ComputerName, RegisteredOrganization and RegisteredOwner provided by your instructor. Example: Computer1, Cisco, and Vicki.
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Expand Microsoft-Windows-Shell-Setup in component 4 specialize of the Answer File area. Locate and select Themes. In the Themes Properties area, set the following value: DefaultThemesOff = false.
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Step 11
In the Windows Image area, locate and expand component Microsoft-Windows-Shell-Setup > right-click OOBE > Add Setting to Pass 7 oobeSystem.
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Select Microsoft-Windows-Shell-Setup in the Answer File area below component 7 oobe System. In the Microsoft-Windows-Shell-Setup Properties area, type the time zone in the TimeZone setting, provided by your instructor. Example: TimeZone = Pacific Standard Time.
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Select OOBE in the Answer File area. In the OOBE Properties area, set the following value: NetworkLocation = Work and ProtectYourPC = 3. This will disable automatically installed updates.
Note: Normally you would set ProtectYourPC to 1, automatically install updates. But to reduce the installation time for this lab we will set the value to 3.
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Step 12
Before validating the answer file, expand all components in the autounattend file to make sure everything is properly added.
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If anything is missing, go back over the lab and add the missing components or settings.

Click Tools > Validate Answer File.
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Select the Validation tab in the Messages area. 
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If you see any error or warning messages, ask your instructor for assistance in correcting them before proceeding with the lab.

If there are no error or warning messages click File > Save Answer File.

Step 13
Copy the autounattend.xml file from C:\Windows_7_Installation to the root of the floppy disk or USB flash drive.
Insert the floppy disk in the floppy drive or connect the USB flash drive to a USB port.

Insert the Windows 7 media in the appropriate drive. 

Restart the computer.

Step 14
When the Press Any Key to Boot from CD or DVD message appears, press any key on the keyboard. 
The installation of Windows 7 will proceed in a completely unattended fashion, and finally you will be presented with the logon screen.

Note: The system will flash on and off several times, restart several times, and other times only a black or blue screen will appear with nothing else shown during the installation.

Logon to the computer using the administrator name and password used in the autounattend file.

What was the name of the file used to automate the installation located on the floppy disk or USB flash drive?
How do you think automating the installation will help the IT Department if they have to repeat the procedure on 100 computers?
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